Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Mate
Posts: 1
Registered: ‎09-14-2017

rough at 1500-3000rpm

have a new to me 2006 200 Evinrude E tech ---very rough at lower rpm --which unfortunately is the speed at which I look for bait on the ocean--.It even overheats at that sluggish speed despite steady water stream --obviously under stress - but runs great at higher rpm and travelling quickly-and no overheating problems there

Have spent over $1000 with evinrude tech trying to diagnose on this computer---computer reads perfect on all cylinders ,injectors etc   he CANNOT find problem ---I am at my wits end with this  and I am sick and tired of having to take it into the shop---he has even called BRP and they told him to try and enrich all the injectors ---that made it even worse ---.

Now he wants to try and change all the injectors ---huge cost and I am not cionvinced that is the issue .

This boat came to me from New Jersy on East coast ---does that make a difference ---thermostat --wise for instance--our water on west coast warmer --.??

Now I went to winterize it and the motor will not even go through the proper diagnostics--with ignition lights etc -no change when going through winterizing process-wont go into fast idle --so can' winterize as advertised  

  could the coputer element on my engine be faulty??

Exhaust pressure  sensor at fault?

just grasping at straws 

Has any one else had this issue 

Any suggestions welcome 

Thank you

Cunny