Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Skipper
Posts: 6
Registered: ‎09-23-2017
Accepted Solution

Engine stopped trimming up

[ Edited ]

I've got a 2000 Ficht 200 HP. When I try and trim the engine up, nothing happens. It's just silent. Down trims fine.

I'm pretty sure I had this problem years again but can't remember how I fixed it. I thought I was able to work around it at the ramp one day.

I tried the trim button on the shifter, on the cowl and on the steering column.

 

Update 

I think it might be the limit switch but I can't remember where it is.

 

Any suggestions?

 

Thanks.

Highlighted
Admiral
Posts: 6,920
Registered: ‎07-14-2011

Re: Engine stopped trimming up

Most likely culprits are the relays, power distribution panel, bad blue/white wire connector, or trim limit switch or connection.

 

Remove port lower motor cover to access trim limit wres (blue/white).

 

 

 


"There is never just one thing wrong with a boat";
                    -- Travis McGee, main character in a book series by John D. McDonald 


 



***************

The factory recommends that a properly trained technician service your Johnson or Evinrude outboard motor. Should you elect to perform repairs yourself, use caution, common sense, and observe safety procedures in the vicinity of flammable liquids, around moving parts, near high-temperature components, and working with electrical or ignition systems.

The information offered here is only general in nature and should not be construed as complete factory approved procedures, techniques, or specifications. Always use the proper service manual for your motor, up-to-date service literature, the correct tools, and have an understanding of how to proceed with troubleshooting and repair methods. If you are unsure or uncomfortable with a procedure, a situation, or a technique, enlist the services of a factory trained technician.


Skipper
Posts: 6
Registered: ‎09-23-2017

Re: Engine stopped trimming up

It was the limit switch. I moved the plunger a few times with a screwdriver and then it worked normally.