Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Mate
Posts: 2
Registered: ‎06-14-2016

115 etec missing (1 week old)

Bought a 2015 leftover, had it for less than 2 weeks now and it's missing. From day 1 it didn't seem right. First it was 3500 rpm and up and now it's like 2000 rpm and up. Had a etec specialist come to my home and hook up to it. Can see the problem but doesn't know why it's doing it besides its cyl#4 acting up. Very dissapointed in this product. My new boat is now in the driveway instead of the lake. I contacted my dealer and they are waiting on approval from brp to go a head and diagnose the issue. Anyone else have this problem? It'sgone threw over 60$ in fuel in very limited use also.
Not a happy boater!
Skipper
Posts: 11
Registered: ‎09-08-2015

Re: 115 etec missing (1 week old)

Hello jsmyth,

 

We are very sorry that your Evinrude has not lived up to your expectations.

 

Please send an email with your serial number and a short description of the engine situation to brp.care@brp.com so we can do the follow up on your case. 

 

Again, please accept our appologies for your inconvenience.

 

Thanks 

 

M. 

 

Sandra C, Owen M, Steve M )
BRPCare
BRP
Follow us on Twitter @BRPCare
Mate
Posts: 2
Registered: ‎06-14-2016

Re: 115 etec missing (1 week old)

Update! Brp is tech is telling brp it's the power head! Brp is making the tech jump through hoops, try this, try that... HEY BRP ITS A 2 WEEKS OLD TOMORROW AND YOU HAVE ONE REALLY PISSED OFF CUSTOMER. REPLACE IT!
Mate
Posts: 4
Registered: ‎06-18-2016

Re: 115 etec missing (1 week old)

115's are having trouble my buddy bought a leftover 15 went into limp mode second day out took it back they said it's a problem from the factory there is filings in the cylinder from machining that wasn't cleaned
Gave it back to him and said if it happens again they will just out a new engine on
His isn't running a 100 percent today so I think it's going back
Mate
Posts: 4
Registered: ‎06-18-2016

Re: 115 etec missing (1 week old)

I've had No problems with my 2012 150
Mate
Posts: 4
Registered: ‎07-16-2016

Re: 115 etec missing (1 week old)

Hi jsymth, I bought a used 115 etec last June it had up to 80 hours on it ,I fished no more than 40 hours that season,then fogged the motor like the book told me ,for the winter this June I started it on the muffs and had no problems. That week I put it in the water got about a mile out and my check engine light came on .So now it's been sitting at the marina waiting to be looked at now going on 4 weeks.I am very aggravated as well. Handleme330