Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Mate
Posts: 1
Registered: ‎02-02-2018

300hp Etec won't Run

Purchased a 300hp etec used.  When I first powered it up the fuel pump ran, but the engine wouldn't start.  Now the fuel pump doesn't run.  The engine won't connect to the computer. Only the servo module and gateway are coming up on the computer. The EMM only shows 1 illuminated light(lanyard start stop), and it goes dim after about 30 seconds.  Any Ideas as to what is wrong?

 

Nick

Highlighted
Admiral
Posts: 7,116
Registered: ‎07-14-2011

Re: 300hp Etec won't Run

 

 

We do need more information to help you. First what is the complete engine model number?

 

What is the engine history? Has it been sitting unused for quite a while?

 

Did you have the motor inspected by an Evinrude tech before purchasing it?

 

 

 


"There is never just one thing wrong with a boat";
                    -- Travis McGee, main character in a book series by John D. McDonald 


 



***************

The factory recommends that a properly trained technician service your Johnson or Evinrude outboard motor. Should you elect to perform repairs yourself, use caution, common sense, and observe safety procedures in the vicinity of flammable liquids, around moving parts, near high-temperature components, and working with electrical or ignition systems.

The information offered here is only general in nature and should not be construed as complete factory approved procedures, techniques, or specifications. Always use the proper service manual for your motor, up-to-date service literature, the correct tools, and have an understanding of how to proceed with troubleshooting and repair methods. If you are unsure or uncomfortable with a procedure, a situation, or a technique, enlist the services of a factory trained technician.