Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Admiral
Posts: 7,118
Registered: ‎07-14-2011

Re: One Year Old 90HO In the Shop

[ Edited ]

 

 

When you said it sputtered and then would not start, did it crank over but not fire up or did you turn the key to START and nothing happened?

 

It sounds like the root cause of the problem you experienced has not been found or corrected.  Ask the dealer if they contacted Evinrude tech service for assistance in finding the problem. Often weird problems are not the fault of the engine but from something related to a boat's fuel or electrical system. All that has to be inspected.

 

You can also send an email to Evinrude with the engine serial number, dealer name, and what has transpired to   http://www.brp.com/en/forms/contact-us.html  

 

 

 


"There is never just one thing wrong with a boat";
                    -- Travis McGee, main character in a book series by John D. McDonald 


 



***************

The factory recommends that a properly trained technician service your Johnson or Evinrude outboard motor. Should you elect to perform repairs yourself, use caution, common sense, and observe safety procedures in the vicinity of flammable liquids, around moving parts, near high-temperature components, and working with electrical or ignition systems.

The information offered here is only general in nature and should not be construed as complete factory approved procedures, techniques, or specifications. Always use the proper service manual for your motor, up-to-date service literature, the correct tools, and have an understanding of how to proceed with troubleshooting and repair methods. If you are unsure or uncomfortable with a procedure, a situation, or a technique, enlist the services of a factory trained technician.


Skipper
Posts: 15
Registered: ‎07-17-2017

Re: One Year Old 90HO In the Shop

It cranks, but won’t fire. Funny though- it did this same senerio earlier in the day where I was running about half throttle and it sputtered, lost power, and shut down. After that first instance it DID start right back up. After fishing an area for about an hour and moving to another area is when it did it the second time and would not restart.

Thanks for the additional information. I’ll contact Evinrude to get them involved.
Highlighted
Skipper
Posts: 15
Registered: ‎07-17-2017

Re: One Year Old 90HO In the Shop

Boat is still in shop.  Been there a total of 6 weeks (two seperate times) so far this year.  I've been trying to contact Evinrude through that link you posted, but after entering all the information and submitting it, it just says that its unavailble and they're trying to fix the issue.  I've even called them and was given a direct email to send my probelm to, have sent an email twice to that address, and still no response.  I spoke to a custom service agent and started to explain what was going on with my motor and then about half way through got mysteriously disconnected.  This whole thing is getting so agrivating.  How is it that I have a brand new boat and motor and yet I can't use it because the motor doesn't even run.  This just doesn't make any sense to me.  If it was anything else, I would have been done with it and returned the darn thing by now!