Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Skipper
Posts: 1
Registered: ‎10-13-2018

2004 250 DI Ficht - Low RPM Engine is Miss Firing

Hi All,

 

Let me start by saying that I am a “newbie” to boat ownership and this is my first boat and Evinrude engine, any and all suggestions are greatly appreciated.

 

Long story short, I purchased a 1990 Pursuit 2350 with a 2004 250 Envinrude DI Ficht Model Number E250FPZSRM EMM Serial Number 5004201.  The engine has about 685 hours on it as today, and I have operated the boat/motor for just about 100 hours and still have not found the issue that is creating what feels like miss firing at low RMPs 1700-2700.

 

The problem that I am having is a significant motor vibration, which I believe is the motor miss firing at RMPs 1700 – 2700.  The motor works very well below that RPM range and above that RPM range up to WOT.  The engine starts easily and idles fine with the normal response in power from idle up to WOT.  When the engine RMPs approach 1700 and the power is still consistent, but the engine starts to vibrate and has a rough run from 1700 RPMs to 2700  The miss firing has been constant since the 1st hour (585) that I used the boat to current hour (685).  In order to resolve the miss fire issue at the specific RPM range, I have done the following:

 

  • Used over 160 gallons of Chevron octane 87 fuel (California blend) – fuel tank holds 124 gallons, no change
  • Replaced all the spark plugs twice and indexed them – no change
  • Used only XD-100 oil
  • De-carbed the engine – no change
  • Cleaned the exhaust diaphragm hose – no change
  • Had the EMM and PDP checked on two different occasions due to heat related issues – each time the EMM and PDP came back with a minor wiring repair - no change
  • Changed the fuel filters, water fuel separator, and oil filter – no change
  • Injectors tested and came back within specifications
  • Compression test performed; ranged from 115 PSI to 120 PSI
  • Fuel pressure is within specifications – no issues with power surges or power drops, power is consistent
  • Fault codes that were previously stored are; 22 Water temp (3 counts), 57 High RMP with low TPS setting (1 count), 28 Shift assist circuit (1 count), 47 Air temp below normal (1 count), 48 Air temp fault (1 count), 38 oil pressure pulse not detected (4 counts) – 39 oil system prime failure (3 counts) more recent at hours 563

 

Any suggestions on similar issues and or fault tracing ideas are greatly appreciated.

 

All the best,

Skipper
Posts: 5
Registered: ‎10-01-2019

Re: 2004 250 DI Ficht - Low RPM Engine is Miss Firing

Any update on this? Im having some issues with my 04 225DI as well. A bit differnt problem than yours but Im curious as to your outcome.