Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Mate
Posts: 2
Registered: ‎07-09-2014

2006 OIL PUMP

     I have a 2006 250 e tech with a possible oil pump problem. Getting frequent 72 fault code, oil pressure low. It's at the dealer now for diagnosis. I was checking on oil pump prices and see that the 2006 pump is different  than 2007 and latter and costs 300 dollars more. Can a newer style pump be retrofitted on my 2006. I've already replaced the oil pressure transducer but I'm still getting occasional faults. I disconnected the horn, ignore the light and otherwise the motor has been running great.    thanks  GQ

Highlighted
Admiral
Posts: 9,505
Registered: ‎07-14-2011

Re: 2006 OIL PUMP

You should have a dealer tech check out your system. It is possible that it is the oil pump assembly, but it is also possible that there is air in the lines causing false alarms or, even though very rare,  engine computer anomalies that can give false alarms.

 

 

 


"There is never just one thing wrong with a boat";
                    -- Travis McGee, main character in a book series by John D. McDonald 


 



***************

The factory recommends that a properly trained technician service your Johnson or Evinrude outboard motor. Should you elect to perform repairs yourself, use caution, common sense, and observe safety procedures in the vicinity of flammable liquids, around moving parts, near high-temperature components, and working with electrical or ignition systems.

The information offered here is only general in nature and should not be construed as complete factory approved procedures, techniques, or specifications. Always use the proper service manual for your motor, up-to-date service literature, the correct tools, and have an understanding of how to proceed with troubleshooting and repair methods. If you are unsure or uncomfortable with a procedure, a situation, or a technique, enlist the services of a factory trained technician.


Highlighted
Mate
Posts: 2
Registered: ‎07-09-2014

Re: 2006 OIL PUMP

      Update on my 2006 250 ETech, the oil pump and pressure are ok, the water in the fuel sensor is ok, no water in the fuel. Whats not ok is my EMM which has been giving these bogus faults for some time. I've been ignoring them because the motor has been running fine otherwise. I see there's another thread about the same problem on a '06 250. I told        the dealer to replace the EMM, $ 1,550 plus labor. Not worth the risk to keep running on the original. Dealer said they would have to send the EMM back to BRP to program the new one.     

Highlighted
Captain
Posts: 168
Registered: ‎07-19-2011

Re: 2006 OIL PUMP

That is incorrect a dealer has, for a while now, being able to commision a new EMM IF in fact the old one is faulty. They should try and do an EMM recovery and do you have the latest revision in it, this can be done once the recovery has been done. Also no wing nuts on the battery I hope.