Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Mate
Posts: 2
Registered: 2 weeks ago

2007 225 etec turns over but will not fire, engine died when throttling down

I recently purchased an older Grady white seafarer with a 2007 etec 225 with what I believe are relatively low hours (I believe around 200) which I understand are not very many, but the previous owner stated that he put about 100 hours on it last summer once he purchased it for a repower for the seafarer so it has seen recent usage. I have only taken it out on small lakes in upstate NY twice until today when I took it into vineyard sound off of cape cod. The engine seemed to be running great, though after our initial run (33ish mph for about 20 minutes at 4200 rpm) the engine had a small amount of smoke coming from it once I returned to idle. After a few minutes we did another run, this time about 5 minutes but same speed. When throttling down the engine almost seemed to shudder slightly and then completely died out with a an alarm sound for a few seconds. I was unable to see if any of the indicator lights came on with the alarm as I was not at the wheel. When trying to restart the engine, the engine turns over perfectly fine but will not start. When turning the key switch before starting the alarm indicators all light up as they should and then turn off one by one, and along with this I can hear the sound of the fuel pump in the engine for about 10 seconds. All of the connections to the batteries were checked and cleaned. When attempting to start it on muffs in the driveway it seemed to backfire out of the exhaust initially as well... I have searched far and wide on these forums but have no seen anything that matches my situation exactly. I would like to just drop it off at a certified evinrude dealer for service but the soonest opening I can get is a month out. Anyone have any advice regarding this?
Highlighted
Mate
Posts: 2
Registered: 2 weeks ago

Re: 2007 225 etec turns over but will not fire, engine died when throttling down

Along with this, the engine seems to only be turning over at about 200rpm according to the gauge on the dash. If we are somehow not getting enough juice to the motor to start it then what could have changed while out on the water? Battery gauge On the dash reads in the green when attempting to start , between 12-14. Thanks again