Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Mate
Posts: 1
Registered: 2 weeks ago

2010 60 HP dying

Hello,

I currently have a 2010 Evinrude etec 60 HP (PN: E60DPLISF)

recently my battery died and had to be replaced, before this there was never an issue with my engine.

Immiediately after this the engine began dying within a minute of starting and then was hard to immediately restart.The time it lasted before dying quickly became less up not it now shutting down/never really starting. There are no warning lights or horns and it passes all the start up self tests.

 

I took the boat out of the water and began trouble shooting. Spark plugs were sparking, cooling water came out of the port, pressure came from the exhaust. This led me to fuel.

 

I have followed this to the HP fuel pump.

I found that if I unplug the connector then the engine will start and throttle on the lift pump alone and not die. I have only done this for a minute or two but was told it will eventually cut out from the lift pump alone.

As soon as I reconnect the electrical connector to the HP pump the engine dies.

 

I meaured the supply to the HP pump and had this around 55v.

I measured the brief pressure output I could get before the engine died from the HP pump outlet around 28psi.

 

I have now removed the HP pump and tested it running dry. There is no excessive noise coming from the pump and it seems to run happily from 12V-32V(all i can generate). It was sucking through all these voltages gradually more as I increased the voltage.

 

Now I am lost. Does anyone have any idea what to test next?

Could there be a poor ground? something with the VST?

 

Highlighted
Captain
Posts: 174
Registered: ‎10-21-2015

Re: 2010 60 HP dying

When testing that pump with an external power source, don’t use anything higher than 12-14 volts as that is the design working voltage. Yes, on engine the pump is connected to a 55 V source but the ground side is pulse width modulated to average that 12 volt value. 

Why does engine die when HP pump connected? Not enough info to diagnose. Try running engine with everything hooked up except power fuel pump from 12 V battery. If that is all good, you should get a current measurement on fuel pump usage. Try to get a voltage reading directly across fuel pump when it is running on 55 V source. It should read 12 V or so

ElderSparky



· Was your question answered? Help others find the answer by clicking "Accept as Solution".
· See a great post? Give a Kudo kudo.pngto show your appreciation!