Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Mate
Posts: 3
Registered: ‎04-07-2018

2012 etec tach problem

2012 smokercraft pro angler with a teleflex tach not working. I removed the tach,cleaned the pins and want to start the engine onland. Question is; can I use the flushing ports with a garden hose or do I need the water intakes submerged in a barrel? Will be a quick start just to see if the tach registers.

 

TIA

Captain
Posts: 196
Registered: ‎09-12-2016

Re: 2012 etec tach problem

You can use a hose in the flush port while running at IDLE.This is documented in the owners manual. 

Mate
Posts: 3
Registered: ‎04-07-2018

Re: 2012 etec tach problem

Appreciate your response, in my research I have been finding there are various opinions on the subject, just don't want to fry the motor.

 

BB

Captain
Posts: 196
Registered: ‎09-12-2016

Re: 2012 etec tach problem

I'be been doing it for years. The caveot is not to run above idle. The owners manuals are online, you can see it from horses mouth if desired.

Mate
Posts: 3
Registered: ‎04-07-2018

Re: 2012 etec tach problem

Thanks again, yes, read the manual, but others say it is not a good idea. Did fire it up and voila, the tach works again. Local tech says once the tack starts to have problems it will just be a matter of time before a complete failure. Hard to find item so I ordered the only one I could find online. When you live in remote areas inventory is a good thing.

 

Anybody else hd a problem the the telefelex tachs?

 

BB