Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Mate
Posts: 3
Registered: ‎05-26-2019
Accepted Solution

Cannot start new 25 hp e-tec.

Hello,

The dealer primed the fuel pump. Then engine was transported on its side and mounted after some manhandling. There is electric start, tilt , control box , tachometer and cable with many connectors. When I turn on the ignition, there is short beep, the four LEDs on tachometer light up and neatly turn off in sequense. On EMM , LED no 4 is lit red - nothing else happens when I turn the switch further. The engine was in neutral - I see there is an issue with wingnuts on the battery and I will replace them, but surely it cannot be that sensitive. Please, what to do?

 

 

 

Captain
Posts: 617
Registered: ‎08-20-2017

Re: Cannot start new 25 hp e-tec.

#4 led indicates that the kill switch lanyard is ok. #3 led (sensors ok) should also be on.
The engine can be programmed for remote throttle/shift/neutral switch control or tiller model control. On tiller only models there is a flat 6? wire plug on top of the flywheel cover that should have a cap/plug in it. For remote control setup the MWS (harness running to tach) would be plugged into that connector.
Check the back of your ignition switch for a yellow/red wire. This would be the neutral switch wire.
Captain
Posts: 617
Registered: ‎08-20-2017

Re: Cannot start new 25 hp e-tec.

You can try disconnecting the MWS harness from the two square plugs on the engine and then try the tiller start button.
Mate
Posts: 3
Registered: ‎05-26-2019

Re: Cannot start new 25 hp e-tec.

Ok, thanks. I don't think there is a tiller start button - no tiller. The neutral switch sounds promising. So, I guess the info that the engine is in neutral comes from the control box. There was much info about routing of switchwire that I did not understand and therefore skipped.
Will check next weekend when I will bring multimeter and appointment to call serviceman at "local" dealer.
Thanks again,
waterBoy
Highlighted
Captain
Posts: 617
Registered: ‎08-20-2017

Re: Cannot start new 25 hp e-tec.

So your engine is a remote model and uses the neutral switch in the control box. The yellow/red wire from the engine harness connects to one coming out of the control box and the other y/r wire out of the box connects to the ignition switch.
It is common practice for a dealer to start the engine with a "shop key switch" plugged directly to the engine when setting an engine up. Your dealer should verify your install for you.
Captain
Posts: 617
Registered: ‎08-20-2017

Re: Cannot start new 25 hp e-tec.

I just got back to work and looked at a 25.
If the neutral switch is in the "in gear" position the 3rd light on the EMM will be off.
Also had the plug on top of the flywheel backwards, tiller model has a harness plugged in there. Remote models will have a cap/ jumper plug on that connection.
Mate
Posts: 3
Registered: ‎05-26-2019

Re: Cannot start new 25 hp e-tec.

Success!

The neutral switch was it. Turned out it is on the engine and an adjustment to the gear-cable ensured the switch was engaged when the engine was in neutral.

Thank you much for kind support!

Captain
Posts: 617
Registered: ‎08-20-2017

Re: Cannot start new 25 hp e-tec.

Thanks for the reply. It helps us and other readers to hear solutions to problems.