Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Captain
Posts: 20
Registered: ‎04-22-2020

Re: Etec 90hp 2008 crank but want start

2 bluewaterbill

 

thanks for reply and advice, yes that black deposits are from deteriorated fuel line, line from lp pump to vst, between fuel filter and vst.

I put a picture on threat, its U shape hose.

 

 

 

yes i check hoses and flush them with water seems pretty much ok, let them on sun to get dry.

 

VST flushed and cleaned,

also strached spring inside FPR and now pressure is about 35psi.

 

 

And,

today is "the" day, i put everything back together yesterday, and after lots of cranking (10-15 times) engine start, and it shut down right after it started but that is because hi pressure fuel system was full of air.

after 15 times or so, it fired up and it worked like with little bit misfire, but after few minutes it worked fine.

So today, i will try to fire it up after engine cool down ower night, and it should start on first crank not after 10 Smiley Sad
fingers crossed

 

will keep you updated

 

and no matter what i will buy bigger battery, and rebuild starter completely.

thanks guys

 

 

Highlighted
Captain
Posts: 20
Registered: ‎04-22-2020

Re: Etec 90hp 2008 crank but want start

[ Edited ]

update

 

it fired up

 

BUT, why there is but,

here is video of cranking

battery fully charged 13,2V 60ah, 530CA

for me it sountds it cranks fast enough, but this is lots of cranking

 

https://imgur.com/a/r21oq0M

 

what do you think?

 

oh yes

on cranking, voltage on starter drops from 13.2v to 10.50v, this sounds a lot for me.

do you know what voltage drop should be if everything is ok?

 

btw, friend have etec 115hp 1100hours, it fires up on first crank with almost empty battery Smiley Sad i guess im not that lucky

 

Highlighted
Captain
Posts: 237
Registered: ‎08-11-2011

Re: Etec 90hp 2008 crank but want start

After seeing the fuel line, one can only suggest you heed Bluewater Bill's suggestions.

 

Replace the fuel lines. All of them.  Remove injector from outer cup, clean injector filters. One behind nozzle and one around injector. Injectors may still be damaged due to debris inside.

 

Clean VST, filter and flush HPpump with a cleaning agent. I have used engine tuner and hydraulic steering oil). Stick it in a container and use 12 volts to flush it clean.

 

Check LPpump for leaking diaphragm.

 

 

Highlighted
Captain
Posts: 20
Registered: ‎04-22-2020

Re: Etec 90hp 2008 crank but want start

guys
one question for my etec 90hp
turning key on, should it turn high pressure pump on for few seconds to prime high pressure fuel system?

Highlighted
Captain
Posts: 237
Registered: ‎08-11-2011

Re: Etec 90hp 2008 crank but want start

No, only on demand.

Highlighted
Captain
Posts: 20
Registered: ‎04-22-2020

Re: Etec 90hp 2008 crank but want start

only on domend?

ok, which means, it can be turned on but in Evinrude diagnostics software for testing purpose only?

i dnot know im asking.

can it be enable as a feature? On key on position it prime fuel system, for x seconds? Like on cars, when you turn key to on positin it turns on fuel pump for 3 sec.

 

 

 

 

 

 

Highlighted
Captain
Posts: 237
Registered: ‎08-11-2011

Re: Etec 90hp 2008 crank but want start

[ok, which means, it can be turned on but in Evinrude diagnostics software for testing purpose only?]

 

Yes.

 

[can it be enable as a feature? On key on position it prime fuel system, for x seconds? Like on cars, when you turn key to on positin it turns on fuel pump for 3 sec.]

 

No, but you can activate it by supplying 12 volt to connector.

Highlighted
Captain
Posts: 813
Registered: ‎08-20-2017

Re: Etec 90hp 2008 crank but want start

The V block engines (90 HO and larger) run the fuel pump at key on. The inline engines do not.
Highlighted
Captain
Posts: 20
Registered: ‎04-22-2020

Re: Etec 90hp 2008 crank but want start

[ Edited ]

thank you, now is clear

 

 

update,

went to boat yesterday afternon,

that from last thursday, so total of 6 days,

put the key on, wait for the lights to go of (like on formula one race Smiley Happy ) and crank...
it fired up with about 3 sec of cranking (like on last video).

To be honest i didnt expect to fire up, but it did. This means that problem is solved, because there is no way that engine would start like this few weeks back. and it was not to HOT, it was 22c outside.

 

what i noticed is that engine cranks much slower with battery that sits up for 6 days, and that same battery that is recharged just 5 minutes with engine running. battery is 2 months old and holds voltage.

So i will take your advice and definitely buy a new battery and i will not buy minimum 75ah 640CA, i will get one step bigger, 90Ah 800CA

 

I dont know what helped, but you guys helped alot i appreciate help, and to summarize what did i done and what fix the problem:

 

- compression check - was ok

- new version of software - didnt start

- new sparkplugs - didnt start

- new gear detector switch - it started but didnt fix the problem

- new fuel line which was bad - no

after this engine still didnt want to start

 

- cleaning injector filters, both filters, ring one and one below nozzle

- raising fuel pressure from 22psi to 38psi

- fully charged battery

engine starts

 

ok, so, i dont know what exactly helped, but i think all little by little made one major problem, so when everything was fixed, engine started.

 

 

to conclude.

this engines are like space shuttles regarding other 4-stroke engines because they are basically car engines, but when space shuttle start to make problems, its pain in the ass Smiley Sad

 

this is my first etec,almost  first expirience with it was bad, but, this engines are awesome, and my nex engine will be e-tec.

 

one more time, guys,  thanks for help