Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Skipper
Posts: 17
Registered: ‎09-17-2018

Re: Fuel lift pump?

Noticed a strange whining noise from vst. Like it is sucking air. When I pump the bulb the noise goes away.
Highlighted
Skipper
Posts: 17
Registered: ‎09-17-2018

Re: Fuel lift pump?

Took the vst home and applied 15 psi to the pressure regulator and it released at 16psi. When taking the vst off last time I broke the vent hose nipple. So I found aluminum tube and was able to look patch it back together...is there a way to test this? Can the float go bad?
Highlighted
Skipper
Posts: 17
Registered: ‎09-17-2018

Re: Fuel lift pump?

I'm going to service the exhaust pressure fitting. If that doesn't help then I'm going for a new vst and pump
Highlighted
Mate
Posts: 2
Registered: 4 weeks ago

Re: Fuel lift pump?

Greg did you ever figure this out. I have a new 150 G1 under load at 4000 rpm cuts out to a stall, pull back on throttle will catch its self back up and can run it around 2000, go back to accelerate and back to stalling.Sounds like the same issues.

Highlighted
Mate
Posts: 2
Registered: ‎04-18-2019

Re: Fuel lift pump?

[ Edited ]

I have a 2018 200 G2 with less than 100 hours experiencing the exact same issue. Seems to run okay <3800 RPM. When getting in the 3800-4100 RPM range you can feel a intermitent bog w/ slighlty reduced power. >4100 RPM has noticebly reduced power/speed and kicks off an intermitent Error Code 137 Fuel Delivery Issue. Initial troubleshooting advice from the dealer was to open up the fuel tank and/or disconnect the carbon canister while driving >4000 RPM to see if it's an air gap/pressure issue. Once that didn't work and error proceeded, needed to bring it in to the dealer. Dealer just confirmed it is a bad fuel pump so will keep you posted if that resolved my issue.