Evinrude E-NATION, for those dedicated to water, power, fishing and fun
Reply
Highlighted
Skipper
Posts: 1
Registered: ‎08-28-2018

Trim gauge stopped working

I have an e-Tec 75 new September 2018. Trim gauge stopped working after bumping over a log at little more than idle speed. Anyone have any suggestions of the cause and or cure? Thanks
Highlighted
Admiral
Posts: 9,210
Registered: ‎07-14-2011

Re: Trim gauge stopped working

Check the mounting and the lever operation of the trim sender for any damage or broken wires.

Refer to the factory service manual for the procedure on testing the resistance through the whole range of travel

 

 

 


"There is never just one thing wrong with a boat";
                    -- Travis McGee, main character in a book series by John D. McDonald 


 



***************

The factory recommends that a properly trained technician service your Johnson or Evinrude outboard motor. Should you elect to perform repairs yourself, use caution, common sense, and observe safety procedures in the vicinity of flammable liquids, around moving parts, near high-temperature components, and working with electrical or ignition systems.

The information offered here is only general in nature and should not be construed as complete factory approved procedures, techniques, or specifications. Always use the proper service manual for your motor, up-to-date service literature, the correct tools, and have an understanding of how to proceed with troubleshooting and repair methods. If you are unsure or uncomfortable with a procedure, a situation, or a technique, enlist the services of a factory trained technician.